Buy all your Marco Polo Accessories at the Club Shop Visit Shop


Awning not closing completely

The fat controller

Active Member
Hi all

At the risk of turning into a spammer, I have another issue I'd like opinions on.

The front of my awning casing isn't closing up completely. I've attached pictures below.

You can see that it's marginal, so not critical by any means but it's annoying and does lead to water ingress, which inevitably then drips down the drivers door.

I've tried winding all the way out and back in - there does seem to be some unevenness in the fabric which I guess could be causing it, but I wasn't able to resolve this simply by winding fully out and then back in. I've also applied silicone to the lower edge of the casing in an attempt to get the flap to slide up over it and seal but to no avail.

So I'm wondering, is this normal? Do those of you with factory awnings find the same or do they close neatly? And do you have any experience or tips on how to deal with the issue?

Many thanks

Phil
 

Attachments

  • IMG_20210915_111131.jpg
    IMG_20210915_111131.jpg
    1.7 MB · Views: 27
  • IMG_20210915_111113.jpg
    IMG_20210915_111113.jpg
    2.2 MB · Views: 24

Steve B

Active Member
I'll have a look later, not noticed it. Mine is at MB today for squeek/rattle rectification (I hope). Got a little 70 plate B class courtesy car, nearly headbutted the steering wheel when I applied the brakes, I'm so used to the weight and the pressure needed for the MP.
 

The fat controller

Active Member
Anyone got a chance to have a look at this? I've some tinkering time over the weekend so hoping I can resolve it... If indeed it needs resolving! Thanks
 

Steve B

Active Member
Sorry for the late reply, mine is similar, not a flush close but its solid and doesn't rattle.

Also, after two days it was acknowledged there are vibrations and rattles from the roof area, not cupboards or draws (I took all our kit out, so it was as we bought it). Couldn't find it/them so has to go back in for another attempt
 

The fat controller

Active Member
Sorry for the late reply, mine is similar, not a flush close but its solid and doesn't rattle.

Also, after two days it was acknowledged there are vibrations and rattles from the roof area, not cupboards or draws (I took all our kit out, so it was as we bought it). Couldn't find it/them so has to go back in for another attempt
Thanks Steve.

No mine doesn't produce a rattle either, just not quite 'so'.

Good luck finding where that rattle does come from!
 

Drazil

New Member
Mine has the same fault and mercedes are doing a warranty claim for a new one as its bent. This is why it wont close on mine.
 

The fat controller

Active Member
Thanks for this. Looks just the same if slightly more pronounced.

Can I ask is the vehicle brand new? Having had mine 9 months or so I'm wary that the dealer may try to blame misuse if it does turn out to be bent... Although it was in fact like this from the off.
 

Drazil

New Member
Mines a 21 plate 11 months old and I reported at about 7 months old. The problem is it wont seat correctly and rattles, also if its not securing safely is it safe is a question to ask.
 
Top